Help installing reverse camera high line version on MK6 golf

Discussion in 'VW Mk6 Golf, Jetta, Beetle, Sportwagen TDI forum' started by poisonivy0, Jun 19, 2013.

  1. poisonivy0

    poisonivy0 New Member

    Joined:
    Jun 19, 2013
    Messages:
    6
    Car:
    Golf MK6
    Hi all ive bought the following (VW Golf MK6 - Rear Emblem High Line Camera KIT with Guidance Line) from carsystems.pl

    I've installed everything and put the car back together but when im coding the camera to my RNS 510 i get the following error code.

    02873 - Control Module for Back-Up Camera (J772)
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 2
    Fault Frequency: 2
    Reset counter: 205
    Mileage: 66650 km
    Time Indication: 0
    Date: 2096.14.11
    Time: 19:13:37


    which im guessing it means it can not talk to the control module.

    Ive check all my wiring and everything seems to be wired correctly.
    I was a bit puzzled when i saw 4 wires that were on the loom that went into the RNS 510 so i took an educated guess and I assumed they are for the CAN.

    So I connected the four wires as follows...
    Red - 12v
    black - earth
    orange - can high
    brown - can low

    Is this correct?

    Wiring looks like this:
    [​IMG]

    Im struggling to find any manuals or documentation regard the highline version reverse cams, so hope you all can help.
     
  2. Keithuk

    Keithuk Super Moderator

    Joined:
    Aug 29, 2010
    Messages:
    7,126
    Car:
    2010 Golf GTD (170) CBBB
    Location:
    Stoke on Trent, England
    Last edited: Oct 30, 2017
  3. poisonivy0

    poisonivy0 New Member

    Joined:
    Jun 19, 2013
    Messages:
    6
    Car:
    Golf MK6
    Thanks Keith for the warm welcome and also for taking the time to reply.

    I've been searching Google like mad and still can not find a help on installing the 'highline' version reverse camera. The link you have posted is for the low reversing camera.
    The wiring is slightly different and the coding is different too for the highline.

    Can't believe how difficult it is to get a little info on the matter.
     
  4. Keithuk

    Keithuk Super Moderator

    Joined:
    Aug 29, 2010
    Messages:
    7,126
    Car:
    2010 Golf GTD (170) CBBB
    Location:
    Stoke on Trent, England
  5. chittychittybangbang

    chittychittybangbang Administrator

    Joined:
    May 23, 2007
    Messages:
    23,900
    Car:
    2006 Jetta TDI
    Location:
    CT
    Probably poor ground or wiring?
     
  6. Tass70

    Tass70 New Member

    Joined:
    Jun 22, 2013
    Messages:
    2
    Car:
    Golf TDI 2012
    I too just bought the same RVC similar to your , I have the same problem too I have those four wires coming from the guidance box harness , brown ,orange,black and red. I don't know where to connect them .. I have been trying to look every where on the Internet ..and I had no lack finding anything .. I have also writen to carsystems.com where I bought this unit.. And there not helpful in supporting me with this problem .. My car currently is all apart in order to do this project.. ( 3days into it !! ) .

    I have emailed carsystems.com again if they don't respond I will return the RVC back .. It's been such a pain..
     
  7. Tass70

    Tass70 New Member

    Joined:
    Jun 22, 2013
    Messages:
    2
    Car:
    Golf TDI 2012
    I have finally got mine rear-emblem-high-line-camera-kit-with-guidance-line to work.. It was quite a pain..

    Ok let's see, this is how it went with the connection.. On the RNS 315
    Make sure the battery is disconnected before you do all this connection.

    Do your plug and play connection to the back of RNS 315 Nav your will have the four extra wire ,

    black wire to be connected to ground ..

    Red +12v wire which is to be connected to the other Long Red +12v wire which is coming from back of the camera to the fuse box which you have created.

    The orange wire is connected / tap into CAN Hight to pin #9 on the RNS 315 Nav ( it's the big black connector ) follow the drawing on the sticker which placed on top of the RADIO.

    The brown wire is connected / tap into to CAN Low to pin #10 on the RNS 315 Nav ( it's the big black connector ) follow the drawing on the sticker which placed on top of the RADIO.



    Keep in mind that you have also created the +12v separate 10A fuse ( the long red 12v wire from rear view camera ).

    Check once more all the wiring / cable connection from rear view camera to the guidance box , and from the guidance box to the RNS 315 Nav .

    Im not responsible for any damage or problems that may result from following these instructions. They are to be used at your own risk. Write down all
    Your original values before attempting to change anything .

    Programming Head Unit
    Using Vagcom/VCDS the headunit requires programming to tell it of the existence of a RVC.

    Connect to controller 37-Navigation and
    then select ( coding-07 ) go to long coding helper under Byte or Bit 6 Rear View Camera (RVC) installed/active check mark this box

    Once you have done this you have to program 19-CAN Gateway controllers then select ( coding-07 ) go to long coding helper under Byte 4-7 select
    60 Model: Offroad

    While still on 19-CAN Gateway controllers now select ( Installation list )
    And check mark 6C Back-up Cam , now save coding. And close controller

    Now you have to add the coding for the Back up Camera .. Look for 6C-Back-up Cam controller, then select
    ( Coding - 07) Go to Software Coding
    And change the code to 0000110 , now save or do it!

    Now close every thing on VCDS AND TEST THE CAMERA ON YOUR VEHICLE. If all is well than put all the panels back to spec of the car.

    Good luck
     
  8. poisonivy0

    poisonivy0 New Member

    Joined:
    Jun 19, 2013
    Messages:
    6
    Car:
    Golf MK6
    So happy that you got it sorted cause that means there is hope for me.
    Dont have my car till monday so ill give this ago then.

    So excited lol :panic:
     
  9. poisonivy0

    poisonivy0 New Member

    Joined:
    Jun 19, 2013
    Messages:
    6
    Car:
    Golf MK6
    Hi all I managed to get the camera sorted, I just had to pay to get it sorted in the end so everythings working, but everything is big and not aligned. Is this right? the guy who fitted it said its probably because its the wrong camera as the vw golfs don't come with high line cameras.

    Check the image, i am parked closest to the crub. Shouldn't the lines be next to the crub indicating where the car is?

    [​IMG]

    Let me know our thoughts. Thanks
     
  10. chittychittybangbang

    chittychittybangbang Administrator

    Joined:
    May 23, 2007
    Messages:
    23,900
    Car:
    2006 Jetta TDI
    Location:
    CT
  11. poisonivy0

    poisonivy0 New Member

    Joined:
    Jun 19, 2013
    Messages:
    6
    Car:
    Golf MK6
  12. tonyzakhia84

    tonyzakhia84 New Member

    Joined:
    Oct 30, 2017
    Messages:
    2
    Car:
    vw mk6 gti
    Location:
    lebanon
    i have vw gti 2012 i have buyed a highline camera with control module j772 and install it to the radio rns315 and everything is ok just i need help for coding can any one help plz
     
  13. Keithuk

    Keithuk Super Moderator

    Joined:
    Aug 29, 2010
    Messages:
    7,126
    Car:
    2010 Golf GTD (170) CBBB
    Location:
    Stoke on Trent, England
    VAG Error Code: 02873


    Fault Location:
    Control Module for Back-Up Camera (J772) - No Signal/Communication

    Possible Cause:
    Wiring/Connector(s).

    Possible Solutions:
    Check/Replace all faulty Wiring/Connector(s).
    Read Measuring Value Blocks (MVB).

    VW Touareg (7L) Back-Up Camera.

    Special Notes:
    Back-Up Camera Calibration:

    After performing service work, the calibration has to be performed too. In detail this is the case after:
    Removing and Installing Rear View Camera (R189).
    Replacing Rear View Camera System Control Module (J772).
    After repair work performed on rear lid following an accident.
    After a vehicle alignment.
    After performing a repair at front or rear axle.

    Prerequisites:
    Calibration Device (VAS 6350) and Distance Laser (VAS 6350/2) positioned as described in the factory repair manual.
    Vehicle must be standing on a firm and even surface.
    Make sure no persons are being/working in/on the vehicle while performing the calibration.
    Do not move the vehicle and do not operate the vehicle doors while performing the calibration.
    Rear Lid must be closed.
    Front Wheels straight, Steering Angle Sensor (G85) close to 0.0 °.
    Ignition must be ON, Engine must NOT be running, you may connect a charger to keep the system voltage up.
    Back-Up Camera active and the MMI shows Back-Up Camera Video Signal.
    Make sure you do NOT have light reflections on the Calibration Device (VAS 6350).
    For vehicles with Level Control, set the Height to automatic.
    [Select]
    [6C - Back-Up Camera]

    [Security Access - 16]
    Enter 22351, to enable the adaptation.
    [Adaptation - 10]
    Channel 005.
    [Read]
    500 mm is the basis value of channel 005. Measure the heights between the Calibration Device (VAS 6350) and the surface (e.g. 80 mm), add 500 mm to it and enter the final value as new value (e.g. 500 + 80 = 580 mm).
    [Test]
    [Save]

    Channel 004.
    [Read]
    20000 mm is the basis value of channel 004, 2855 mm is the wheelbase (7L Touareg). Measure the Distance between the Calibration Device (VAS 6350) and the rear axle (e.g. 1500 mm), and subtract it from 20000 mm minus 2855 mm enter the final value as new value (e.g. 20000 - 2855 - 1500 = 15645 mm).
    Note: If you were redirected to this page, please use the wheelbase in mm of the vehicle you are working with, 2855mm is for the 7L Touareg in the example above.
    Tiguan 5N = 2601
    Passat 3C = 2709
    Passat 35/CC = 2710
    Passat 36 = 2712
    Sharan = 2920
    Phaeton 3D = 2881 (Short), 3001 (long)
    Bentley Continental GT = 2745
    Bentley Continental Flying Spur = 3065
    The VW Touareg (7P) is NOT supported at this time.
    [Test]
    [Save]
    Channel 001
    [Read]
    To save your above adaptation save a new value of 1 to channel 001.
    [Test]
    [Save]

    [Done, Go Back]
    Now double check the calibration status.
    Measuring Value Blocks (MVB) - 08
    Block 130
    [Go!]
    Block 005 Field 3 (Calibration Status).
    Specification: 0x0000 (Calibration Successful).
    [Done, Go Back]
    [Close Controller, Go Back - 06]


    As taken from my new Free EOBD II Error Codes software
     
  14. tonyzakhia84

    tonyzakhia84 New Member

    Joined:
    Oct 30, 2017
    Messages:
    2
    Car:
    vw mk6 gti
    Location:
    lebanon
    keithuk very thx but i need first to code the j772 ecu before i can calibrate and look i have find yesterday a code 0030008 and its ok for that code but screen isnt turn to camera on reverse maybe the code is faulty ? i dont know what do to can u help give me ur number we will text by whatsapp or something else if u can aid me thank u
     

Share This Page